PROBLEM:
If you're attempting to login to Kronos Workforce Ready and you receive an error "Invalid Login Information".
CAUSE:
The username or password has been entered incorrectly.
SOLUTION:
Check your username and password. Check to see if your cap locks are on? If you are still unsure of your password, please use the "Forgot Password" link to reset your password.
If you make 5 failed login attempts, your account will lock automatically. Your account will automatically unlock in 30 minutes and there is no need to request that your account be unlocked.